Back to overview
Degraded

Unplanned 4G service outage in localised area.

Mar 12 at 09:57pm AEDT
Affected services
Current Local Outages

Updated
Mar 13 at 01:57pm AEDT

We are continuing to experience a significant local network outage affecting 4G in the following localities: Laverton 6440, Leonora 6438.

The issue stemmed from Local Power Failure, impacting approximately 994 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 12/03/2026 07:55 PM
Last update: 13/03/2026 01:28 PM
Next update: 14/03/2026 02:14 AM
Issue restore time: UNKNOWN

Updated
Mar 13 at 09:57am AEDT

We are continuing to experience a significant local network outage affecting 4G in the following localities: Laverton 6440, Leonora 6438.

The issue stemmed from Local Power Failure, impacting approximately 994 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 12/03/2026 07:55 PM
Last update: 13/03/2026 09:14 AM
Next update: 14/03/2026 02:14 AM
Issue restore time: 13/03/2026 09:00 PM

Updated
Mar 13 at 08:27am AEDT

We are continuing to experience a significant local network outage affecting 4G in the following localities: Laverton 6440, Leonora 6438.

The issue stemmed from Local Power Failure, impacting approximately 994 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 12/03/2026 07:55 PM
Last update: 13/03/2026 01:38 AM
Next update: 13/03/2026 05:47 PM
Issue restore time: 13/03/2026 09:00 PM

Updated
Mar 13 at 02:27am AEDT

We are continuing to experience a significant local network outage affecting 4G in the following localities: Laverton 6440, Leonora 6438.

The issue stemmed from Local Power Failure, impacting approximately 994 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 12/03/2026 07:55 PM
Last update: 13/03/2026 01:38 AM
Next update: 13/03/2026 05:47 PM
Issue restore time: 13/03/2026 09:00 PM

Updated
Mar 13 at 01:27am AEDT

We are continuing to experience a significant local network outage affecting 4G in the following localities: Laverton 6440, Leonora 6438.

The issue stemmed from Local Power Failure, impacting approximately 994 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 12/03/2026 07:55 PM
Last update: 13/03/2026 12:47 AM
Next update: 13/03/2026 05:47 PM
Issue restore time: 13/03/2026 09:00 PM

Created
Mar 12 at 09:57pm AEDT

We are currently experiencing a significant local network outage affecting 4G in the following localities: Laverton 6440, Leonora 6438.

The issue stemmed from Local Power Failure, impacting approximately 994 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 12/03/2026 07:55 PM
Last update: 12/03/2026 09:22 PM
Next update: 13/03/2026 03:22 AM
Issue restore time: 13/03/2026 01:00 PM