Back to overview
Degraded

Unplanned 4G service outage in localised area.

Apr 27, 2026 at 5:57am UTC
Affected services
Current Local Outages

Resolved
Apr 27, 2026 at 6:57am UTC

We recently experienced a significant local network outage affecting 4G in the following localities: Buronga 2739, Cardross 3496, Gol Gol 2738, Irymple 3498, Mallee 2738, Mildura 3500, Monak 2738, Nichols Point 3501, Paringi 2738, Red Cliffs 3496, Trentham Cliffs 2738, Wentworth 2648.

The issue stemmed from Parent: Site failure, impacting approximately 985 services. Services have now been restored. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: RESOLVED
Date & time of issue: 27/04/2026 09:57 AM
Last update: 27/04/2026 04:01 PM
Next update: UNKNOWN
Issue restore time: 28/04/2026 10:00 AM

Updated
Apr 27, 2026 at 6:27am UTC

We recently experienced a significant local network outage affecting 4G in the following localities: Buronga 2739, Cardross 3496, Gol Gol 2738, Irymple 3498, Mallee 2738, Mildura 3500, Monak 2738, Nichols Point 3501, Paringi 2738, Red Cliffs 3496, Trentham Cliffs 2738, Wentworth 2648.

The issue stemmed from Parent: Site failure, impacting approximately 985 services. Services have now been restored. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: RESOLVED
Date & time of issue: 27/04/2026 09:57 AM
Last update: 27/04/2026 04:01 PM
Next update: UNKNOWN
Issue restore time: 28/04/2026 10:00 AM

Created
Apr 27, 2026 at 5:57am UTC

We are currently experiencing a significant local network outage affecting 4G in the following localities: Buronga 2739, Cardross 3496, Gol Gol 2738, Irymple 3498, Mallee 2738, Mildura 3500, Monak 2738, Nichols Point 3501, Paringi 2738, Red Cliffs 3496, Trentham Cliffs 2738, Wentworth 2648.

The issue stemmed from Parent: Site failure, impacting approximately 985 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 27/04/2026 09:57 AM
Last update: 27/04/2026 03:12 PM
Next update: UNKNOWN
Issue restore time: 28/04/2026 10:00 AM