Back to overview
Degraded

Unplanned 4G service outage in localised area.

Jun 11, 2026 at 4:57am UTC
Affected services
Current Local Outages

Resolved
Jun 11, 2026 at 3:57pm UTC

We recently experienced a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Services have now been restored. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: RESOLVED
Date & time of issue: 11/06/2026 10:10 AM
Last update: 12/06/2026 12:55 AM
Next update: 12/06/2026 06:13 PM
Issue restore time: 12/06/2026 06:30 PM

Updated
Jun 11, 2026 at 3:27pm UTC

We recently experienced a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Services have now been restored. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: RESOLVED
Date & time of issue: 11/06/2026 10:10 AM
Last update: 12/06/2026 12:55 AM
Next update: 12/06/2026 06:13 PM
Issue restore time: 12/06/2026 06:30 PM

Updated
Jun 11, 2026 at 11:28am UTC

We are continuing to experience a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 11/06/2026 10:10 AM
Last update: 11/06/2026 08:36 PM
Next update: 12/06/2026 06:13 PM
Issue restore time: 12/06/2026 06:30 PM

Updated
Jun 11, 2026 at 10:58am UTC

We are continuing to experience a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 11/06/2026 10:10 AM
Last update: 11/06/2026 08:13 PM
Next update: 12/06/2026 06:13 PM
Issue restore time: 12/06/2026 06:30 PM

Updated
Jun 11, 2026 at 9:57am UTC

We are continuing to experience a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 11/06/2026 10:10 AM
Last update: 11/06/2026 07:25 PM
Next update: 12/06/2026 11:44 AM
Issue restore time: 12/06/2026 06:30 PM

Updated
Jun 11, 2026 at 8:57am UTC

We are continuing to experience a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 11/06/2026 10:10 AM
Last update: 11/06/2026 06:37 PM
Next update: 12/06/2026 11:44 AM
Issue restore time: 12/06/2026 06:30 PM

Created
Jun 11, 2026 at 4:57am UTC

We are currently experiencing a significant local network outage affecting 4G in the following localities: Mutitjulu 0872, Petermann 0872.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1006 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 11/06/2026 10:10 AM
Last update: 11/06/2026 02:34 PM
Next update: 12/06/2026 11:44 AM
Issue restore time: 12/06/2026 06:30 PM